Trying to get my 725g mower deck attached to 9661 mower deck

Stephen d

Forum Newbie
Joined
Mar 18, 2019
Threads
1
Messages
2
Thank you in advance for any help you may be able give.
I’m trying to figure out what I have wrong on a 1999 725g with a 9661 deck. I did extensive welding repairs to this deck and rebuilt it and now trying to get it going after years apart. I think I have it together properly but the left rear of deck is hanging really low and loose when the deck is raised up. It seems like it’s not latching but it appears to be latched properly but still sags on the left rear and scalps on that side. When I raise the lift handle the right side starts to raise right away and the left not so much. Does the short stabilizer bar on discharge side have anything to do with this? Or the two lever handle bushings in the height adjustment mechanism? The short stabilizer was rusted solid and had to be heated to remove and the position was lost on threaded rod. The bushings in the lever handle were missing so I made some out of a 1/2” spacers and not sure I have them correct but the lever does raise and lower deck but not evenly. The higher I raise it the worse it sags on left side.
It seems like the problem is at the latch area where the load transfer arm with the d rings is. Per Grasshopper tech instructions I used a pry bar to lift the left rear of deck to get the latch to snap in place but appears to already be latched but sagging lower compared to right side. I unlatched and relatched it but is the same Thank you for any help you can give.
 

Stephen d

Forum Newbie
Joined
Mar 18, 2019
Threads
1
Messages
2
Part of my problem is I’ve never had this grasshopper mower together and mowing before. The deck was pretty much junk before I welded on it extensively so I’m not ruling out the possibility it’s warped but don’t think that’s the case.
I’m hoping somebody familiar with how the older front mount 61” manual decks work will see this and offer some help.

1. What does the small stabilizer link on discharge side adjust?
When deck was disassembled for repair the original adjustment was lost so I reinstalled it in the middle of the threads.
2. What areas should I look for worn out parts Or things assembled wrong? Like the chains that go from deck to tractor. I attached them to the traction arms but am wondering what the other little arms that can attach chains to are for?
I watched some tube videos by mowermedic1 that were helpful but didn’t solve problem. Any other ideas from anybody would be appreciated
 
Top