Walk behind My new Gravely XD3 self-propelled

WriteAway

Member
Joined
Aug 20, 2012
Threads
3
Messages
21
Update: June 2019
My XD3 is running well except for the drive system starting to feel “clunky” at engagement. Will try to adjust drive handle cable before anything else.
The engine is running strong, and easily starts with 1-2 pulls hot or cold.
Side discharge chute clogs with annoying regularity.
WriteAway
 
Last edited:

QuantumRift

Forum Newbie
Joined
Apr 10, 2019
Threads
0
Messages
5
Maybe you should inspect the drive belt and see if the belt/pully area is packed with grass and junk.
 

WriteAway

Member
Joined
Aug 20, 2012
Threads
3
Messages
21
Nope, not much debris under there. Cable adjustment took care of it for a while. Think it needs a new drive belt and adjustment. But now the left rear wheel is askew, possibly broken. It still powers along, but it will go to the dealer to get it all resolved, along with an oil change.
 

WriteAway

Member
Joined
Aug 20, 2012
Threads
3
Messages
21
My XD3's left rear axle bolt snapped a few days ago, almost flush with the end of the axle. Although the Subaru/Robin EA175 runs with no issue, the engine compression seems weak. That will be checked out Monday, when the mower goes in for an estimate to have the both rear axle bolts replaced, driveline checked/adjusted/fixed as needed and an oil change.

If the compression is weak, I am guessing it will be more expensive to repair than to buy a new mower. No dealers in my immediate area seem willing to work on the EA175 Subaru, so I hope for no issues to be found engine-wise.
 
Top