Lawn Boy 1978 7268

steveleb66

Forum Newbie
Joined
Nov 26, 2019
Threads
2
Messages
3
Bought this mower in 1980 the best running machine i ever owned. Unfortunately I am having a problem. it doesn't have a primer ball and to start it i use a little starting fluid. Never had a problem until a month or so ago it would rev high rpm's when started and then go back to idle speed. I check the light speed switch and it is on fast speed. I retired it from cutting grass, but i do use it to vacuum up grass clippings I hate to sweep.

Thanks for any help
 

bertsmobile1

Lawn Royalty
Joined
Nov 30, 2014
Threads
25
Messages
13,013
:welcome::welcome:
Time to clean out the carb, Clean out the fuel tank and replace the filter if there is one in the fuel line.
If it has an in tank filter that can be a bit harder to find a replacement but some can be back flushed.
Pop a screwdriver inside the fuel line and rotate it a few times, if there are little bits of rubber on the end, replace the fuel line.
 

steveleb66

Forum Newbie
Joined
Nov 26, 2019
Threads
2
Messages
3
The only t do is thing I didn't do is change the float on the carburetor.
 

jp1961

Well-Known Member
Joined
Jul 23, 2013
Threads
38
Messages
734
Hello,

Parts tree.com does show a primer bulb for this model. I assume it broke a while back? Is there a small rubber line going somewhere on the carb?

You shouldn't have to use starting fluid to start it (assuming it has decent compression, the crankcase seals are good and you're getting spark)..

The high revving might be dirt binding the governor lever, I know the older Lawn-Boys had a lever for light and normal operation. These models had a relatively lightly constructed centrifugal governor on them, dirt may be an issue.

Regards

Jeff
 
Top