Homelite UT20044B won't stay running

mmanter

Active Member
Joined
Jul 15, 2013
Threads
17
Messages
98
Well I'm new to gas powered trimmers so I'm not sure what's going on.

I pumped the primer button, and pulled the string only for the trimmer to die. Finally it would run but when I put the choke to half choke or run it dies. Am I doing something wrong? I've only had electric trimmers before so this is new to me.

Not sure if something's wrong or if I'm just not doing something right.

Thanks for any information!
 

ILENGINE

Lawn Pro
Joined
May 6, 2010
Threads
23
Messages
6,572
Most likely the carb either needs adjusted, or removed, cleaned, and a repair kit installed. Some of the newer trimmer require the choke to be on for a bit, so the engine can warm up.
 

mmanter

Active Member
Joined
Jul 15, 2013
Threads
17
Messages
98
Most likely the carb either needs adjusted, or removed, cleaned, and a repair kit installed. Some of the newer trimmer require the choke to be on for a bit, so the engine can warm up.
Found out the fuel line in the tank is busted so i'm gonna replace that. In addition the carb is real nasty so I'm gonna replace it as well.
 

mmanter

Active Member
Joined
Jul 15, 2013
Threads
17
Messages
98
Well I went ahead & replaced the entire gas tank after having issues with replacement lines working. Paid $14 for a new tank, and it is better but still not right. It'll run now but not all the time. No idle at all, and doesn't always run under throttle. The replacement carb is on the way so I won't have to worry about it again.
 

mmanter

Active Member
Joined
Jul 15, 2013
Threads
17
Messages
98
New carb fixed the trimmer. $10 carb from ebay and it runs perfect.
 
Top