17 HP Kawasaki problems

marcof3

Forum Newbie
Joined
Sep 7, 2020
Threads
1
Messages
4
Hey guys,
I have a Great Dane mower with a 17 HP Kawasaki engine. I let my nephew borrow it and when he finished mowing he sprayed the mower off with a water hose.
(Don't loan your mower !) Now the motor was running rough and smoking. I thought maybe a cracked head or head gasket. I first replaced the head gaskets on both cylinders.
This did not fix my problem. Upon taking the heads off there was some oil in #1 cylinder. So, I replaced the cylinder head with a new head. The engine starts but
runs really rough and smokes some but only runs about 30 seconds and then dies and will not start until I let the engine set for a few hours.
Any help or ideas will be greatly appreciated.
 

Scrubcadet10

Lawn Addict
Joined
Sep 24, 2017
Threads
137
Messages
3,391
what color is the smoke? If it's white there may be water in the the fuel
If it's black it's running rich, if it's a blue color it's oil burning.
 

marcof3

Forum Newbie
Joined
Sep 7, 2020
Threads
1
Messages
4
what color is the smoke? If it's white there may be water in the the fuel
If it's black it's running rich, if it's a blue color it's oil burning.
The smoke is white mostly. It turns darker after running just a few seconds. I ran the gas line to a gas can of fresh gas and got the same results.
The engine ran for about 30 seconds and died. Not understanding why it quits running. If it was burning oil the engine would run longer than
30 seconds but blow smoke, Correct?
 

Hammermechanicman

Lawn Addict
Joined
Jan 10, 2020
Threads
11
Messages
1,581
Did the air filter get wet? Do both spark plugs look the same? Oily? Carbon fouled?
Did you check spark to both cylinders?
 

marcof3

Forum Newbie
Joined
Sep 7, 2020
Threads
1
Messages
4
Did the air filter get wet? Do both spark plugs look the same? Oily? Carbon fouled?
Did you check spark to both cylinders?
Air filter was not wet but took it out and still done the same. I changed the plugs when I had the heads off.
Neither looked any different than the other. I have not checked spark but I've had the engine run on one cylinder
before. Both new plugs look like they have been firing.
 

7394

Lawn Addict
Joined
Sep 5, 2014
Threads
55
Messages
2,589
You seem to be throwing money at it. Do some diagnostic tests first..

1 would have been a Leak Down test to determine if it was top end or rings etc.

2 would be compression test.
 

marcof3

Forum Newbie
Joined
Sep 7, 2020
Threads
1
Messages
4
You seem to be throwing money at it. Do some diagnostic tests first..

1 would have been a Leak Down test to determine if it was top end or rings etc.

2 would be compression test.
Thanks for the good advice. Will do.
 
Top