two different issues onn 2 different B and S small engines

jackcu

Active Member
Joined
Apr 1, 2013
Threads
27
Messages
56
I have a craftsman push mower that has the thermostat controlled choke mechanism on it. The issue is that when the engine is hot the thermostat will not allow the choke arm to go to choke position so that it will start when hot. The thermostat arm remains forward thus keeping the choke arm forward and not allowing the choke plate to close until the thermostat cools off. That means once you stop the engine you cant restart it until the engine cools. I have replaced both the thermostat and the air valve spring but still have the problem.

Issue number 2. On a toro pressure washer, the engine runs when cold then when it it gets hot it starts missing and smoking a little bit, running very rough. Cleaned carb but no change. Is this a valve issue or maybe broken ring?????
 

Rivets

Lawn Royalty
Joined
Mar 11, 2012
Threads
46
Messages
11,200
First issue, the auto choke is doing exactly what it is supposed to do. You don’t need to choke an engine which is hot. Second issue, check to see if you have good spark when it starts running rough. Sound to me like the coil is starting to break down.
 

jackcu

Active Member
Joined
Apr 1, 2013
Threads
27
Messages
56
Thanks for the reply. I agree that Auto choke is working. My question is why can't I get mower started when the engine is hot?


Also thanks for advice on coil. I didn't think about that .
 

Rivets

Lawn Royalty
Joined
Mar 11, 2012
Threads
46
Messages
11,200
Both problems may be the result of the coil. Check to see if you have good spark when hot restarting.
 
Top