Echo PAS 2400 will not restart after running

Sean2202

Member
Joined
Aug 27, 2018
Threads
13
Messages
41
Greetings,

I found an old Echo PAS 2400 (507422) on the back shelf of my workplace that had been sitting for some time. The fuel lines had a pin hole in them so I replaced them all with 90097Y fuel system kit after talking to my dealer. Added some fresh mixed gas and a clean up and she fired right up and seemed to run well. A few tanks of mixed gas later and the guys say that "It runs great initially but It wont start after it is turned off". The spark is strong and the on off switch is working. I started it up when it was cold and used it for about 15 minutes then turned it off and just as they said it would not fire like it has lost its prime. If a tiny bit of starter fluid is sprayed in the plug hole it will fire right back up and run fine again until it is shut off. The primer bulb is in good shape and the unit itself does not appear to have much visual usage. Seems it is also becoming harder to fire up initially as well.

Multiple units are being used with the same mixed gas and this is the only one that is having issues.

Is this a case of "just replace the carb from age and ethanol" or is there something else I am missing.

Also is the mixed gas ratio different on these older models? I do see that they take a different spark plug compared to other newer echos that I have BPM7Y vs. BPM8Y

Thanks for any help
Sean
 

EngineMan

Lawn Addict
Joined
Jun 12, 2012
Threads
7
Messages
2,256
I would be going for a carb clean and a carb rebuild kit, and go from there...!
 
Top