Briggs push mower engine 126T02-0675-B2

cbs123

Member
Joined
May 26, 2020
Threads
12
Messages
38
Hello,

I've got a briggs engine on a push mower that has me stumped. It wasn't running. First thing I found is the coil was spaced way too far from the flywheel. Reset the gap and the mower cranked up and ran good. Put the air filter base and filter on and it sounds like its flooding. Brand new air filter and spark plug.

Checked the flywheel key, and it is 100% fine. No partial shear or anything like that. Ordered a cheap carb just to see if something was wrong with the carb, but the new carb does the same thing. Runs good until you put the air filter on and it starts spitting and sputtering (rich fuel mixture is what it sounds like)

Any ideas what might be going on?
 

cbs123

Member
Joined
May 26, 2020
Threads
12
Messages
38
Does this engine have a primer or the manual or auto choke system.
Hey IL,

It has the auto-choke system. I've checked to make sure it's not stuck on choke. The choke is fully "off choke" so that's not what's causing it. I'm almost tempted to believe the new air filter is somehow not letting enough air through. Although that would be the first time I've ever seen that happen. ???
 

ILENGINE

Lawn Pro
Joined
May 6, 2010
Threads
25
Messages
7,582
Hey IL,

It has the auto-choke system. I've checked to make sure it's not stuck on choke. The choke is fully "off choke" so that's not what's causing it. I'm almost tempted to believe the new air filter is somehow not letting enough air through. Although that would be the first time I've ever seen that happen. ???
Don't think I have ever seen it on briggs other than a filter that was plugged with fine dust that was the same color as the filter media. Honda I have seen several that will restrict air flow if contaminated with water.
 

bertsmobile1

Lawn Royalty
Top Poster Of Month
Joined
Nov 29, 2014
Threads
44
Messages
16,934
Important question
Did you buy the cheapest parts you found on Amazon/ebay or known quality pars from a mower shop ?
If it floods when the air filter is on but runs fine without it then either the jets are very slightly clogged or the air filter is bad
There is a lot of sub-standard parts that the factory sold for scrap that end up being sold as OEM on line.
 

cbs123

Member
Joined
May 26, 2020
Threads
12
Messages
38
Important question
Did you buy the cheapest parts you found on Amazon/ebay or known quality pars from a mower shop ?
If it floods when the air filter is on but runs fine without it then either the jets are very slightly clogged or the air filter is bad
There is a lot of sub-standard parts that the factory sold for scrap that end up being sold as OEM on line.
The carb that was on the mower was the stock oem carb. I ordered a carb online straight from Bangcock, lol. Both do the same thing. The old oem one acutally ran a little better, but both flood out when I put the new air filter on. I may try a different air filter just to eliminate that as a potential problem. Just weird because the air filter looks just like any other air filter. A pleated paper air filter.

Possible it's too restrictive somehow???
 

cbs123

Member
Joined
May 26, 2020
Threads
12
Messages
38
are you using 491588S filter?
Also is it blowing black smoke?
yes, it's an aftermarket 491588. I've never had a aftermarket paper pleated air filter cause any restrictions, but anythings possible I suppose. Still haven't got back around to trying a new filter let. I'll keep yall posted
 
Top