Ariens ikon xd52 firing issue

Misterb422

Forum Newbie
Joined
Apr 23, 2020
Threads
1
Messages
1
I just got a brand new Ikon xd52 delivered from lowes the other day which wasn't assembled correctly first off. I think I've fixed the issues with that but it doesn't fire right up. I've followed the instructions properly. It turns over but just doesn't fire up. With the choke pulled up it just turns then I mess with the choke a little it fires up. Seems off to me but I'm new to the zero turn world. Any advice?
 

bertsmobile1

Lawn Royalty
Joined
Nov 29, 2014
Threads
32
Messages
14,792
This is the real hidden price when buying cheap and not getting the mower fully assembled and ( hopefully) test run before delivery.
SO we are all talking the same language what you are sayings the engine cranks ( rotates) fine but does not start .
What do you mean by mess with the choke ?
You should have the choke on full when starting.
So I would start by removing the air filter and making sure that the choke is fully closed when the engine is in the cold start settings.
It would also be of great assistance if you told us what engine is fitted and the full engine number .
Lots of people here very familiar with the foibles of particular engines but not conversant with the xd52 .
 

nomad369

Forum Newbie
Joined
Jun 3, 2020
Threads
0
Messages
2
You mentioned you followed the instructions, but I'm not sure if you've seen this video:

Seems like a known behavior and not necessarily an assembly issue or part defect/failure.
 

gainestruk

Well-Known Member
Joined
Oct 12, 2013
Threads
4
Messages
366
Please let your engine warm up a couple minutes before you go full throttle, doing what he showed on video is hard on engine, be nice to your engine and it will give you good service, also change oil and filter between 5-10 hours and do it with engine hot to get the metal flakes out from the break in.
 
Top