Results 1 to 1 of 1
  1. #1

    Join Date
    Jun 2018
    Posts
    5
    Location
    Pennsylvania
    Mower
    Troy-Bilt

    mysteriously engaging deck blades

    First time user here. Hoping someone can help. I have a Troy Bilt Bronco with a 46" deck. I don't have model # handy but it's about 9 years old. With Engine running and blades disengaged, the blades will engage when I lower the deck from the top position to the # 3 or 4 position. If I lower it to the 2 position the blades will disengage again. Problem seems to be getting worse and I am concerned the blades wont disengage at all.
    I am somewhat mechanically inclined but wouldn't even know what to look for if I drop the deck.
    Any help appreciated.
    .

  2.  

Similar Threads

  1. Engaging deck Blades
    By Weed Whisperer in forum Gravely/Ariens Forum
    Replies: 19
    Last Post: 05-21-2018, 06:21 PM
  2. Repairs blades not engaging.
    By bugnutz in forum MTD Forum
    Replies: 3
    Last Post: 07-29-2017, 05:41 PM
  3. Mower deck D110 - blades not engaging
    By oliver_cfc in forum John Deere Forum
    Replies: 9
    Last Post: 01-03-2017, 10:41 PM
  4. Craftsman 19.5 hp - blades not engaging
    By tatwalsh in forum Small Engine & Mower Repair
    Replies: 2
    Last Post: 08-06-2014, 05:55 PM
  5. blown fuse when engaging blades
    By zero in forum Small Engine & Mower Repair
    Replies: 3
    Last Post: 09-02-2013, 05:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •