Results 1 to 3 of 3

Thread: JD RX75

  1. #1

    Join Date
    Jun 2012
    Posts
    9
    Location
    Texas
    Mower
    I Don't Own a Mower :(

    JD RX75

    RX75 has been running fine. This morning, I start to mow the yard. After about 15 mins, I stop and put it in neutral w/ engine running. Go to put it in gear and it won't move. Rock it back and forth, shift to Reverse, pump the brake and clutch, engage and disengage the mower deck, and nothing. Then, I put it in 7th speed and it takes off. I stop and try to put it back in 1st or 2nd speed and it won't move. Put it back in 7th and it won't move. Then suddenly I hear a screech and this smoke starts to come from under the engine. The engine seems to be running fine, so I'm assuming it's a clutch or transmission. Any suggestions?

  2.  

  3. #2

    Join Date
    Aug 2012
    Posts
    7
    Location
    Texas
    Mower
    John Deere

    Re: JD RX75

    The smoke is coming from the traction drive belt. This mower has some years on it. The transaxle has probably broken something inside. Some parts are available and some are not (NLA). The drive belt is a pain to put on unless you have experience with these rear engine mowers. I have two GX85's. Love them.

  4. #3

    Join Date
    Aug 2012
    Posts
    7
    Location
    Texas
    Mower
    Toro

    Re: JD RX75

    This is weird I just fixed a JD RX75 with a belt problem was a pain in the *** to put back on but luckily the owner was nice and gave a hand.Actually the drive belt was a breeze it was the deck belt that gave me trouble since I removed the deck for easy access.All in all a good job.

Similar Threads

  1. RX75 bucking in forward
    By brackish in forum Small Engine & Mower Repair
    Replies: 1
    Last Post: 03-05-2012, 05:49 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •